RIAForge Forums Home | Search | RSS
New Topic Reply   Previous Page  Page: 1   Previous Page

Thread: Problems on CF8
Created on: 04/02/08 04:09 PM Replies: 2
ryanwood


Joined: 01/09/07
Posts: 5
Problems on CF8
04/02/08 4:09 PM

I just tried CFEasyMock out on CF8. Created the factory just fine, but as soon as I tried to call mf.createMock(...), I got a nasty Servlet error. I'd like to use this, but all our development is on CF8 now.

-Ryan

500

javax.servlet.ServletException
   at coldfusion.xml.rpc.CFCServlet.invoke(CFCServlet.java:154)
   at coldfusion.xml.rpc.CFCServlet.doGet(CFCServlet.java:264)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:740)
   at org.apache.axis.transport.http.AxisServletBase.service(AxisServletBase.java:327)
   at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
   at coldfusion.bootstrap.BootstrapServlet.service(BootstrapServlet.java:89)
   at jrun.servlet.FilterChain.doFilter(FilterChain.java:86)
   at coldfusion.monitor.event.MonitoringServletFilter.doFilter(MonitoringServletFilter.java:42)
   at coldfusion.bootstrap.BootstrapFilter.doFilter(BootstrapFilter.java:46)
   at jrun.servlet.FilterChain.doFilter(FilterChain.java:94)
   at jrun.servlet.FilterChain.service(FilterChain.java:101)
   at jrun.servlet.ServletInvoker.invoke(ServletInvoker.java:106)
   at jrun.servlet.JRunInvokerChain.invokeNext(JRunInvokerChain.java:42)
   at jrun.servlet.JRunRequestDispatcher.invoke(JRunRequestDispatcher.java:284)
   at jrun.servlet.ServletEngineService.dispatch(ServletEngineService.java:543)
   at jrun.servlet.jrpp.JRunProxyService.invokeRunnable(JRunProxyService.java:203)
   at jrunx.scheduler.ThreadPool$DownstreamMetrics.invokeRunnable(ThreadPool.java:320)
   at jrunx.scheduler.ThreadPool$ThreadThrottle.invokeRunnable(ThreadPool.java:428)
   at jrunx.scheduler.ThreadPool$UpstreamMetrics.invokeRunnable(ThreadPool.java:266)
   at jrunx.scheduler.WorkerThread.run(WorkerThread.java:66)
Link | Top | Bottom
ryanwood


Joined: 01/09/07
Posts: 5
RE: Problems on CF8
04/02/08 4:47 PM

As a followup, this happens only when trying to mock a cfc that is a subclass. If I remove the extended="" attribute, the error goes away. So, it may not be CF8 related.

-Ryan
Link | Top | Bottom
m_steele


Joined: 03/27/08
Posts: 5
RE: Problems on CF8
04/03/08 2:46 PM

This is actually a problem with the reflect.Proxy class. The issue was in a recursive call that would create proxy functions for the superclasses. This has been fixed. I've included an extends="xx" in the sample code for the mock so you can see it work in the sample.

Tnaks for catching this!
Link | Top | Bottom

New Post
Please login to post a response.